import re
regex = re.compile(r"^(\d+\.\d+).*", flags=re.MULTILINE)
test_str = "45.09 y"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)