$re = '/^(\d+\.\d+).*/m';
$str = '45.09 y';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;