using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:adafruit)(?:[0–9a-z\-_\t .]{0,20})";
string input = @"adafruit_api_key = ""x-xfiu9qulytekagka60cn2ey1rrrba4""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}