re = /(?i)(?:adafruit)(?:[0–9a-z\-_\t .]{0,20})/m
str = 'adafruit_api_key = "x-xfiu9qulytekagka60cn2ey1rrrba4"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end