const regex = /CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)', 'gm')
const str = `CREATE INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE CLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE NONCLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}