re = /CREATE INDEX (.*)|CREATE CLUSTERED INDEX (.*)|CREATE NONCLUSTERED INDEX (.*)/m
str = 'CREATE INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE CLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]
CREATE NONCLUSTERED INDEX [NonClusteredIndex-20230503-134755] ON [dbo].[AaaAccount]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end