using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[;}{]{1}\n{1}[^\S\r\n]*\/\/";
string input = @"test;
//comment with no newline between
test;
//comment with newline between";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}