re = /[;}{]{1}\n{1}[^\S\r\n]*\/\//m
str = 'test;
//comment with no newline between
test;
//comment with newline between'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end