package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[;}{]{1}\n{1}[^\S\r\n]*\/\/`)
var str = `test;
//comment with no newline between
test;
//comment with newline between`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}