using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(?:\[[^][]*]|\([^()]*\))";
string substitution = @"";
string input = @"Deadpool 2 [Region 4](Blu-ray)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}