$re = '/\s*(?:\[[^][]*]|\([^()]*\))/m';
$str = 'Deadpool 2 [Region 4](Blu-ray)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;