package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*(?:\[[^][]*]|\([^()]*\))`)
var str = `Deadpool 2 [Region 4](Blu-ray)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}