using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])\.";
string input = @"111.111.111.111";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}