import Foundation
let pattern = #"(\d|\d\d|[01]\d\d|2[0-4]\d|25[0-5])\."#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"111.111.111.111"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}