const regex = /休憩\S*\s*(なし|無し)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('休憩\\S*\\s*(なし|無し)', 'gm')
const str = `休憩なし
休憩:なし
休憩時間: 無し
休憩 無し
休憩 なし`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}