import re
regex = re.compile(r"休憩\S*\s*(なし|無し)", flags=re.MULTILINE)
test_str = ("休憩なし\n"
"休憩:なし\n"
"休憩時間: 無し\n"
"休憩 無し\n"
"休憩 なし")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")