import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\(([а-яё]\\|?)+\\)|[CV^$])*) ([а-ё]) ((\\(([а-яё]\\|?)+\\)|[CV^$])*)";
final String string = "(ш|ж|ч|ц|щ)и(й)\n"
+ "а\n"
+ "(ь|ъ)е\n"
+ "ш(ь)V\n"
+ "Vй$\n"
+ "Vё\n"
+ "ж(ь)V";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}