const regex = new RegExp('((\\(([а-яё]\\|?)+\\)|[CV^$])*) ([а-ё]) ((\\(([а-яё]\\|?)+\\)|[CV^$])*)', 'g')
const str = `(ш|ж|ч|ц|щ)и(й)
а
(ь|ъ)е
ш(ь)V
Vй\$
Vё
ж(ь)V`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}