$re = '/((\(([а-яё]\|?)+\)|[CV^$])*) ([а-ё]) ((\(([а-яё]\|?)+\)|[CV^$])*)/x';
$str = '(ш|ж|ч|ц|щ)и(й)
а
(ь|ъ)е
ш(ь)V
Vй$
Vё
ж(ь)V';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);