package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|\s)#(\w+)\b`)
var str = `#test1.#test2 #test3 www.google.com/#test4 www.google.com/hello#test5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}