$re = '/(^|\s)#(\w+)\b/';
$str = '#test1.#test2 #test3 www.google.com/#test4 www.google.com/hello#test5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);