package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]+)\s*(seconds|minutes)`)
var str = `5 seconds (match)
5 minutes (match)
5 whatever (no match)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}