re = /([0-9]+)\s*(seconds|minutes)/
str = '5 seconds (match)
5 minutes (match)
5 whatever (no match)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end