$re = '/([0-9]+)\s*(seconds|minutes)/';
$str = '5 seconds (match)
5 minutes (match)
5 whatever (no match)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);