using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?!https:\/\/www\.foxnews\.com\/(opinion|us|politics|media)\/).)*$";
string input = @"https://www.foxnews.com/ffffffffffasdf/court-finds-fault-with-warrantless-searches-of-global-travelers-laptops-phones";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}