const regex = /^((?!https:\/\/www\.foxnews\.com\/(opinion|us|politics|media)\/).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?!https:\\\/\\\/www\\.foxnews\\.com\\\/(opinion|us|politics|media)\\\/).)*$', 'gm')
const str = `https://www.foxnews.com/ffffffffffasdf/court-finds-fault-with-warrantless-searches-of-global-travelers-laptops-phones`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}