re = /^((?!https:\/\/www\.foxnews\.com\/(opinion|us|politics|media)\/).)*$/m
str = 'https://www.foxnews.com/ffffffffffasdf/court-finds-fault-with-warrantless-searches-of-global-travelers-laptops-phones'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end