use strict;
my $str = '########### Absolutly Fine ################
Mainstreet.
Mainstreet
Main Street
Big New mainstreet
Mainstreet-New
Mains Str.
St. Alexander Street
Übermorgen Straße
John Kennedy Street
Bahnhofstr.
Leonhard-Eck-Str.
Älterweg
Graf-Anton-Weg
Alexanderstraße
Prof.-Ernst-Nathan-Straße
Prof.-Albert-Einstein-Weg
Prof. Ernst-Nathan-Straße
Prof. Albert-Einstein-Weg
########## Not very common but fine!!! ###################
A 1
K 7
H 2
P 1
I 7
E 7
T 3
######## Not okay ################
A
B
Mainstreet #+;:_*´`?=)(/&%$§!
Mainstreet#+;:_*´`?=)(/&%$§!
Mainstreet 2
Mainstreet..
Mainstreet§
';
my $regex = qr/^(?:[A-Z] \d|[^\W\d_]{2,}\.?)(?:[- '’][^\W\d_]+\.?)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}