$re = '/^(?:[A-Z] \d|[^\W\d_]{2,}\.?)(?:[- \'’][^\W\d_]+\.?)*$/m';
$str = '########### Absolutly Fine ################
Mainstreet.
Mainstreet
Main Street
Big New mainstreet
Mainstreet-New
Mains Str.
St. Alexander Street
Übermorgen Straße
John Kennedy Street
Bahnhofstr.
Leonhard-Eck-Str.
Älterweg
Graf-Anton-Weg
Alexanderstraße
Prof.-Ernst-Nathan-Straße
Prof.-Albert-Einstein-Weg
Prof. Ernst-Nathan-Straße
Prof. Albert-Einstein-Weg
########## Not very common but fine!!! ###################
A 1
K 7
H 2
P 1
I 7
E 7
T 3
######## Not okay ################
A
B
Mainstreet #+;:_*´`?=)(/&%$§!
Mainstreet#+;:_*´`?=)(/&%$§!
Mainstreet 2
Mainstreet..
Mainstreet§
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);