# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:[A-Z] \d|[^\W\d_]{2,}\.?)(?:[- '’][^\W\d_]+\.?)*$"
test_str = ("########### Absolutly Fine ################\n"
"Mainstreet.\n"
"Mainstreet\n"
"Main Street\n"
"Big New mainstreet\n"
"Mainstreet-New\n"
"Mains Str.\n"
"St. Alexander Street\n"
"Übermorgen Straße\n"
"John Kennedy Street\n"
"Bahnhofstr.\n"
"Leonhard-Eck-Str.\n"
"Älterweg\n"
"Graf-Anton-Weg\n"
"Alexanderstraße\n"
"Prof.-Ernst-Nathan-Straße\n"
"Prof.-Albert-Einstein-Weg\n"
"Prof. Ernst-Nathan-Straße\n"
"Prof. Albert-Einstein-Weg\n\n\n"
"########## Not very common but fine!!! ###################\n"
"A 1\n"
"K 7\n"
"H 2\n"
"P 1\n"
"I 7\n"
"E 7\n"
"T 3\n\n\n"
"######## Not okay ################\n"
"A\n"
"B\n"
"Mainstreet #+;:_*´`?=)(/&%$§!\n"
"Mainstreet#+;:_*´`?=)(/&%$§!\n"
"Mainstreet 2\n"
"Mainstreet..\n"
"Mainstreet§\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.