$re = '/berry|^apple$|watermelon/m';
$str = 'strawberry
orange
blueberry
apple
pineapple
watermelon
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);