# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b\w+\b) (\b\w+\b) (\b\w+\b)/\U\1\U\2\U\3/gm;t' <<< "aaa bbb ccc"