const regex = /(\b\w+\b) (\b\w+\b) (\b\w+\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b\\w+\\b) (\\b\\w+\\b) (\\b\\w+\\b)', 'gm')
const str = `aaa bbb ccc`;
const subst = `\U\1\U\2\U\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);