use strict;
my $str = 'aaa bbb ccc';
my $regex = qr/(\b\w+\b) (\b\w+\b) (\b\w+\b)/mp;
my $subst = '\\U\\1\\U\\2\\U\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";