const regex = /(\d+-\d+-\d+\s\d+:\d+:\d+,\d+)\s(\S+\s-\s\S+)\s(\w+)\s(.*)(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+-\\d+-\\d+\\s\\d+:\\d+:\\d+,\\d+)\\s(\\S+\\s-\\s\\S+)\\s(\\w+)\\s(.*)(.*)', 'gm')
const str = `2019-10-20 17:01:17,252 [//127.0.0.1/ - /envcenter/shippinglist/query_shippinglist_settings.json?productId=ap_philippines] ERROR impl.GitRepositoryInfoRemoteImpl - 请求gitlab api失败
java.io.FileNotFoundException: http://gitlab.alipay-inc.com/api/v3/projects/intl-sre-bm%2Fdevopaas-agent-id`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}