re = /(\d+-\d+-\d+\s\d+:\d+:\d+,\d+)\s(\S+\s-\s\S+)\s(\w+)\s(.*)(.*)/m
str = '2019-10-20 17:01:17,252 [//127.0.0.1/ - /envcenter/shippinglist/query_shippinglist_settings.json?productId=ap_philippines] ERROR impl.GitRepositoryInfoRemoteImpl - 请求gitlab api失败
java.io.FileNotFoundException: http://gitlab.alipay-inc.com/api/v3/projects/intl-sre-bm%2Fdevopaas-agent-id'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end