# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(ts.*?)(\]\s+\+)//gm;t' <<< "c[ts[0],99:99,99:99] + 5 - d[ts[1],99:99,99:99, ts[2]] + 5"