use strict;
my $str = 'c[ts[0],99:99,99:99] + 5 - d[ts[1],99:99,99:99, ts[2]] + 5';
my $regex = qr/(ts.*?)(\]\s+\+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";