$re = '/(ts.*?)(\]\s+\+)/m';
$str = 'c[ts[0],99:99,99:99] + 5 - d[ts[1],99:99,99:99, ts[2]] + 5';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;