using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:,(?!(?<=\d.)\d)|(?!\b\.\b)\.|[!():;?])+";
string input = @"i was born in germany (near Frankfurt, in the center of the country) but i live in france. what about you? i know you have a similar story.
abc.io is a company that employs 10,000 people, half of them in greece.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}