import re
regex = re.compile(r"(?:,(?!(?<=\d.)\d)|(?!\b\.\b)\.|[!():;?])+", flags=re.MULTILINE)
test_str = ("i was born in germany (near Frankfurt, in the center of the country) but i live in france. what about you? i know you have a similar story.\n"
"abc.io is a company that employs 10,000 people, half of them in greece.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")