re = /(?:,(?!(?<=\d.)\d)|(?!\b\.\b)\.|[!():;?])+/m
str = 'i was born in germany (near Frankfurt, in the center of the country) but i live in france. what about you? i know you have a similar story.
abc.io is a company that employs 10,000 people, half of them in greece.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end