const regex = /(\(*)([\w][\w\d.]*)\s*([<>!=]{1,2}|like|not like|is null|is not null|in\s*\()?\s*(?!and|or)(?:(?:(between )(['"]?)(.*?)(\5)( and )(['"]?)(.*?)(\9))|(?:(['"]?)(.*?)(\12)))\s*(\)*)\s+(?!'|")\s*(and|or)?\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\(*)([\\w][\\w\\d.]*)\\s*([<>!=]{1,2}|like|not like|is null|is not null|in\\s*\\()?\\s*(?!and|or)(?:(?:(between )([\'"]?)(.*?)(\\5)( and )([\'"]?)(.*?)(\\9))|(?:([\'"]?)(.*?)(\\12)))\\s*(\\)*)\\s+(?!\'|")\\s*(and|or)?\\s*', 'g')
const str = `id between 3 and 10 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}