import re
regex = re.compile(r"(\(*)([\w][\w\d.]*)\s*([<>!=]{1,2}|like|not like|is null|is not null|in\s*\()?\s*(?!and|or)(?:(?:(between )(['\"]?)(.*?)(\5)( and )(['\"]?)(.*?)(\9))|(?:(['\"]?)(.*?)(\12)))\s*(\)*)\s+(?!'|\")\s*(and|or)?\s*")
test_str = "id between 3 and 10 "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")