$re = '/<Notes>(?:(?!<\/?Notes>|sample)[\s\S])*sample[\s\S]*?<\/Notes>/m';
$str = 'TextBefore<Notes>this is sample notes</Notes>TextWithsample<Notes>this is sample notes</Notes>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);