re = /<Notes>(?:(?!<\/?Notes>|sample)[\s\S])*sample[\s\S]*?<\/Notes>/m
str = 'TextBefore<Notes>this is sample notes</Notes>TextWithsample<Notes>this is sample notes</Notes>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end