$re = '/(?<==).*?(?=#{2}|$)/m';
$str = ' Identifier1 = Value1 ## Comment
Something = SomeData
Name = information\\\\t\\\\t\\\\t## More comments!
Nam2 = information';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);