re = /(?<==).*?(?=#{2}|$)/m
str = ' Identifier1 = Value1 ## Comment
Something = SomeData
Name = information\\\\t\\\\t\\\\t## More comments!
Nam2 = information'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end