$re = '/\d{4}\-(?:1[0-2]|0?[1-9])\-(?:[12]\d|3[01]|0?[1-9])/';
$str = '2020-05-01
2020-5-3
2020-6-30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);