// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d{4}\-(?:1[0-2]|0?[1-9])\-(?:[12]\d|3[01]|0?[1-9])").unwrap();
let string = "2020-05-01
2020-5-3
2020-6-30";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}